Leo_zhou

练习时长八年半的运维工程师

kubernetes版本apiversion简单说明

在使用yaml文件部署Deployment项目时,出现过

error: error validating "xx-Deployment.yaml": error validating data: found invalid field Ports for v1.Container; if you choose to ignore these errors, turn validation off with --validate=false

的错误,对于kubernetes中的apiversion做一个简单的说明:

1.extensions/v1beta1是用于kubernetes版本在1.6之前,资源申明

2.apps/v1beta1是用于1.6-1.9版本之间

3.apps/v1是1.9版本以后使用

目前使用的是1.16.3版本可以正常使用apps/v1
《kubernetes版本apiversion简单说明》

apps是指应用的场景,例如可以使用deployment,service,namespace等,几乎涵盖了申明资源,不过也可以不写,进行通用匹配资源,但也有些资源需要特殊申明,具体可以通过命令查看。
《kubernetes版本apiversion简单说明》

点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注